Skip to main content

A large portion of our clients come to us after they been hacked. Once we log into the site, we can have a look to try and find the cause. In nearly all cases the client was hacked via a vulnerability in one of their plugins.

Out of date plugins are the primary causes of hacked websites – they are an easy target for hackers due to the scale of WordPress – over 60% of sites powered by a content management system (CMS) are WordPress – that equates to literally hundreds of millions of sites. So if a popular plugin is found to have vulnerability, and it isn’t patched quickly, anyone using that plugin is a potential victim.

So how can BlueSix help?

BlueSix’s Managed WordPress Hosting service provides a range of security for your website.

  1. Starting at the web server itself, we use the most recent Linux versions, that have been specifically designed to provide the best possible protection for WordPress websites. Things like custom configuration, fail2ban software, firewall/restricted port access, SSH-only access
  2. Next up we have the WordPress software itself. We enable automatic updates for WordPress. We run updates across all of our client sites 3 times per week, ensuring that your plugins and themes are never out of date.
  3. Our next layer of security is Wordfence, and almost ‘industry standard’ piece of software for WordPress that blocks out known attacks and vulnerabilities, and also includes a bunch of other handy tools like automatically blocking bot users that attempt to login.
  4. Finally, we have CloudFlare, which includes tools like security, caching and CDN. We setup custom rules for each client depending on the markets they operate in. Countries that are usually the source of nefarious traffic are completely blocked. This not only makes your site safer, but faster, since their traffic doesn’t even reach our server.

All this adds up to an extremely fast, secure and safe hosting environment.

Enough Talk, Let's Build Something Together